[sldev] [HELP] Skipping incompatible lllmozlib2 library

Russell G. Wells rgwells at techno-logix.com
Tue Mar 3 16:58:02 PST 2009


I'm having trouble getting the linux viewer RC 1.22.10 to link. (I hope this 
is the right place to post this) I want to contribute to the viewer 
development, specifically on the linux code base. I figure this this is a 
dependency issues on my side, but I don't see it.

The following error is being generated:

Linking CXX executable secondlife-bin
master: http://secondlife.com/app/message_template/master_message_template.msg
current: /home/rgwells/projects/slv-1.22.10/linden/scripts/messages/message_template.msg
Refreshing master cache from 
http://secondlife.com/app/message_template/master_message_template.msg
--- PASS ---
Older
    missing message RezRestoreToWorld, did you mean to deprecate?
    in message RegionHandshake: missing 1 extra blocks
    in message RegionInfo: missing 1 extra blocks

/usr/bin/ld: skipping 
incompatible /home/rgwells/projects/slv-1.22.10/linden/indra/../libraries/x86_64-linux/lib_release_client/libllmozlib2.a 
when searching for -lllmozlib2
/usr/bin/ld: cannot find -lllmozlib2
collect2: ld returned 1 exit status
make[2]: *** [newview/secondlife-bin] Error 1
make[1]: *** [newview/CMakeFiles/secondlife-bin.dir/all] Error 2
make: *** [all] Error 2


System info:
-------------------
Distribution: Kubuntu 8.04
Kernel version: 2.6.24-23-generic #1 SMP Mon Jan 26 01:04:16 UTC 2009 x86_64 
GNU/Linux
CPU: AMD Phenom 9850 Quad-Core @ 2.5 Ghz
GPU: GeForce 9500 GT
NVidia driver: 173.14.12


General compiling notes:
------------------------

I won't go into all the dependencies I needed to install compile, as I should 
reproduce the list on a clean install of my distribution. But here is the 
short list of steps I took after I installed the missing stuff.

1. unpacked the source code, linux libs, and artwork into a working directory.

2, ran the <work_dir>/linden/indra/develop.py to generate linux makefiles.

3. copy header files for the following elements into the
<work_dir>/linden/libraries/<target_platform>/include directory.

    cp -a /usr/include/atk-1.0 ${TARGETDIR}/include/

    # linux GUI framework
    cp -a /usr/include/gtk-2.0 ${TARGETDIR}/include/
    cp -a /usr/lib/gtk-2.0/include/* ${TARGETDIR}/include/gtk-2.0/

    # general support framework
    cp -a /usr/include/glib-2.0 ${TARGETDIR}/include/
    cp -a /usr/lib/glib-2.0/include/* ${TARGETDIR}/include/glib-2.0/

    # text layout with emphasis on internationalization
    cp -a /usr/include/pango-1.0 ${TARGETDIR}/include/

    # 2D vector graphics support
    cp -a /usr/include/cairo/* ${TARGETDIR}/include

    # IPC support
    cp -a /usr/include/dbus-1.0/dbus/ ${TARGETDIR}/include/

    # ELF file format debugging support (Stack trace)
    mkdir ${TARGETDIR}/include/ELFIO
    cp ${ELFIO}/ELFIO/*.h ${TARGETDIR}/include/ELFIO/
    cp ${ELFIO}/ELFIO/libELFIO.a ${TARGETDIR}/lib_release_client/

NOTE: This is the minimal set I needed to compile (tried lots more as 
suggested for older builds on the wiki).


4. ran a compile.
* had to fix error in <work_dir>/linden/indra/newview/llappviewerlinux.cpp 
line 258  needed to change from

    fprintf(StraceFile, "%d:\t", btpos);

to
    fprintf(StraceFile, "%lu:\t", btpos);


5. compile again
* compile completes OK, but the link step generates the error listed above.

Other thoughts:
--------------------

I saw in aan old post, that version FL-1.13.3.58185 would not compile on linux 
unless LL_LIBXUL_ENABLED was defined to 0.  Is this still true?
I tried it, but still got the link error.

Russell G. Wells



More information about the SLDev mailing list