[sldev] Re: building from src: Can't find settings_files.xml

Lear Cale lear.cale at gmail.com
Mon Feb 2 09:51:31 PST 2009


BTW, the only place I see this file is at

  ./linden/indra/newview/app_settings/settings_files.xml

Not in any build directory.


On Mon, Feb 2, 2009 at 12:21 PM, Lear Cale <lear.cale at gmail.com> wrote:

> Thanks, Ambrosia :)
>
> ALL_BUILD was the default project.  I changed it to secondlife-bin.
>
> In properties for secondlife-bin, I don't see "working directory".
> For "Configuration Properties -> General", I see
> Output Directory (set to "RelWithDebInfo") and Intermediate Directory
> (set to "secondife-bin/RelWithDebInfo).  Is that what you meant?
>
> I get the same error, running this way.
>
> Also, with 'secondlife-bin' selected as the default project, when I
> "build solution", it builds nothing (skipping ALL_BUILD).
>
> Thanks again,
> Jeff
>
>
>
>   On Mon, Feb 2, 2009 at 11:23 AM, Ambrosia <chaosstar at gmail.com> wrote:
>
>> Lear:
>>
>> When trying to start the client from the MSVC, do these steps first:
>>
>> Right click the secondlife-bin project, and set it as the startup project.
>> Then go into the project properties, and set
>> \indra\build-VC80\release\ (or debug, or relwithdeb) as the working
>> directory.
>>
>> then try again. Basically the working directory is set to
>> \indra\build-VC80\, which is wrong.
>>
>>
>> On Mon, Feb 2, 2009 at 17:09, Lear Cale <lear.cale at gmail.com> wrote:
>> > Any ideas on why this is happening (can't find
>> > linden\indra\build-VC80\app_setting\settings_files.xml)?
>> >
>> > Thanks!
>> >
>> > On Fri, Jan 30, 2009 at 5:40 PM, Lear Cale <lear.cale at gmail.com> wrote:
>> >>
>> >> I'm building from source, latest available release (1.21), having
>> trouble,
>> >> using MSVS 2005 Express.
>> >>
>> >> The instructions don't say how to build the target using MSVS 2005
>> >> Express, so I guessed: use File -> Open Project/solution, navigate to
>> >> "linden/indra/build-VC80/viewer.vcproj
>> >> linden/indra/build-VC80/viewer.vcproj", open that, select
>> RelWithDebInfo,
>> >> and build.
>> >>
>> >> Ran into the llkdu.dll problem.  Pulled one from my viewer, for now.  I
>> >> find two different "solutions" for this problem in the wiki but they're
>> >> inaccurate or out of date.
>> >>
>> >> Solution built.  Wen to run it; and MSVS doesn't know what the
>> executable
>> >> file is.  I figure it must be
>> >> "\linden\indra\build-VC80\newview\relwithdebinfo\secondlife-bin.exe"
>> and try
>> >> that.
>> >>
>> >> It can't find fmod.dll.  I find that and copy it into the same
>> directory
>> >> as the exe file.
>> >>
>> >> Now when I run the viewer (from MSVS) I get an error from the viewer.
>>  It
>> >> can't find linden\indra\build-VC80\app_setting\settings_files.xml
>> >>
>> >> Has anyone actually built and run this thing using MSVS 2005 Express?
>> >>
>> >> I'm an experienced software engineer, but I work on Unix development
>> >> systems, for embedded software.  I'm a newb to MSVS.
>> >>
>> >> Oh: two places that list dependencies for DXSDK and MS Server SDK
>> >> conflict.  One says to use latest versions, the other says to use
>> earlier
>> >> ones.  Which is correct?  I'm using latest.  My guess is this has
>> nothing to
>> >> do with my problems, but it would be nice to resolve this
>> contradiction.
>> >>
>> >> Thanks
>> >> Lear
>> >>
>> >>
>> >
>> > _______________________________________________
>> > Policies and (un)subscribe information available here:
>> > http://wiki.secondlife.com/wiki/SLDev
>> > Please read the policies before posting to keep unmoderated posting
>> > privileges
>> >
>>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.secondlife.com/pipermail/sldev/attachments/20090202/f89bc286/attachment.htm


More information about the SLDev mailing list