[sldev] Voice on 64bit Linux

Ricky kf6kjg at gmail.com
Mon Sep 22 23:13:09 PDT 2008

I have been having many fits and starts with voice since it's release, and
I'd love to have it working.. So I upped the log level in the client.
(Advanced > Debug Settings > VivoxDebugLevel = 5)

Here's the specs section from the Connector log:
20:26:34.0000, 0xf73df6c0, INFO , initialize   Machine Configuration=
                                               <OSRevision>Linux version
2.6.25-gentoo-r7 (root at glave) (gcc version 4.1.2 20070214 ( (gdc 0.24, using
dmd 1.020)) (Gentoo 4.1.2 p1.1)) #1 SMP Thu Aug 14 22:07:27 PDT

                                               <ProcessorName>AMD Athlon(tm)
64 X2 Dual Core Processor 6000+</ProcessorName>

20:26:34.0000, 0xf73df6c0, INFO , initialize   Sdk Configuration=

                                                     <Device>ALSA Capture on
                                                     <Device>ALSA Capture on
HDA NVidia</Device>
                                                     <Device>ALSA Capture on
USB Device 0x41e:0x4048</Device>
                                                     <Device>ALSA Capture on
SB X-Fi Surround 5.1</Device>
                                                     <Device>ALSA Software
on default</Device>
                                                     <Device>ALSA Software
on HDA NVidia [AD198x Analog]</Device>
                                                     <Device>ALSA Software
on HDA NVidia [AD198x Digital]</Device>
                                                     <Device>ALSA Software
on SB X-Fi Surround 5.1 [USB Audio]</Device>
                                                     <Device>ALSA Software
on SB X-Fi Surround 5.1 [USB Audio #1]</Device>
                                                     <Device>Wave File
Capture on default</CaptureDevice>

I also paid attention to the SLVoice log found in ~/Library/Logs/Vivox

For some reason it's having tribbles connecting to my recording device (any
one of them) but that's ok, other apps have issues too with finding my mic..
I would like to be able to at least listen to my friend's conversations! :D

Here's my question: Is there a dependency on a system copy of mediastreamer
from linphone?  I ask beacuse of these lines from the Connector log:
20:26:34.0000, 0xf73df6c0, INFO , RTP                        oRTP-0.11.2
20:26:35.0000, 0xf73df6c0, INFO , RTP                        Card OPENAL:
ALSA Capture on default added
20:26:35.0000, 0xf73df6c0, INFO , RTP                        Cannot open
directory /usr/local/antisip/lib/mediastreamer/plugins: No such file or
20:26:35.0000, 0xf73df6c0, ERROR, RTP                        No such filter
with id 28
20:26:35.0000, 0xf73df6c0, INFO , am_options.c:340           Range audio
port start at: 22860
20:26:35.0000, 0xf73df6c0, TRACE, vx_sip_and_media_mgr_init  Exiting
vx_sip_and_media_mgr_init successfully
20:26:35.0000, 0xf73df6c0, TRACE, initialize                 In initialize,
creating request processor thread

On Gentoo, media-libs/mediastreamer is hard masked.  Meaning that it is
considered too unstable to allow any but the very determined to install it.

aka Cron Stardust
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.secondlife.com/pipermail/sldev/attachments/20080922/34701384/attachment.htm

More information about the SLDev mailing list