[sldev] Re: 1.19.1 build issues - big main thread

Alissa Sabre alissa_sabre at yahoo.co.jp
Tue Apr 8 07:17:45 PDT 2008


I tried (aka r84244, i.e., no RC) bundle, and it worked.

Thank you, Soft, for doing the rerolling.

Details follow:

> >  I built Mac and Linux this morning and ran both without problems.
> >  Speak up if you're seeing something different.

I tried it on three platforms:

* Macintosh: Intel Mac mini, OS X 10.4.11, Universal configuration;

* Linux: Fedora 8, NVIDIA GeForce 7025 + NVIDIA Driver 169.12, scons
  BTARGET=client STANDALONE=no DISTCC=no, g++ 3.4; and

* Windows: XP SP2, Visual C++ Express 2005 SP1, both ReleaseNoOpt and
  ReleaseForDownload configurations, using "Manual conversion of
  solution/project files" method.

All of them primarily compiled fine and worked fine.

I faced two issues during the test builds.

On Macintosh build, I got a warning "suggest use of -bind_at_load, as
lazy binding may result in errors or different symbols beig used" when
Linking AutoUpdater.  I believe this is not new to 1.19.1 series,
altough I don't find any JIRA issue filing on this.

On Linux build, I got trouble with the issue VWR-5734 and needed to
remove the g++ command line option "-D_FORTIFY_SOURCE" as a

Although I have not yet used the resulting viewers for long time, I
experienced no problems with them.

> This should mean all three
> platforms are working from source.


    Alissa Sabre
GANBARE! NIPPON! Win your ticket to Olympic Games 2008.

More information about the SLDev mailing list