[sldev] cannot open file 'OpenJPEG.lib'

Anna Gulaev annagulaev at gmail.com
Sun Nov 18 13:32:47 PST 2007


Building 1.18.4.3, debug version, on WIndows, VS 2003:

------ Build started: Project: newview, Configuration: Debug Win32 ------

Executing pre-build batch file
master:
http://secondlife.com/app/message_template/master_message_template.msg
current: c:\sl\sl_1_18_4_3\linden\scripts\messages\message_template.msg
--- PASS ---
Same
PREBUILD SUCCESSFUL
Linking...
LINK : fatal error LNK1104: cannot open file 'OpenJPEG.lib'



This happens because, or course, there is no such file. Both the 1.1.1 and
1.2 downloads for openjpeg have no such file in the debug version. There is
a OpenJPEGd.lib, though. I tried renaming it but then got a whole host of
other errors:



------ Build started: Project: newview, Configuration: Debug Win32 ------

Executing pre-build batch file
master:
http://secondlife.com/app/message_template/master_message_template.msg
current: c:\sl\sl_1_18_4_3\linden\scripts\messages\message_template.msg
--- PASS ---
Same
PREBUILD SUCCESSFUL
Linking...
MSVCRT.lib(MSVCR71.dll) : error LNK2005: _strtol already defined in
LIBCMTD.lib(strtol.obj)
MSVCRT.lib(MSVCR71.dll) : error LNK2005: _isxdigit already defined in
LIBCMTD.lib(_ctype.obj)
MSVCRT.lib(MSVCR71.dll) : error LNK2005: _fwrite already defined in
LIBCMTD.lib(fwrite.obj)
MSVCRT.lib(MSVCR71.dll) : error LNK2005: _calloc already defined in
LIBCMTD.lib(dbgheap.obj)
MSVCRT.lib(MSVCR71.dll) : error LNK2005: _realloc already defined in
LIBCMTD.lib(dbgheap.obj)
MSVCRT.lib(MSVCR71.dll) : error LNK2005: _free already defined in
LIBCMTD.lib(dbgheap.obj)
MSVCRT.lib(MSVCR71.dll) : error LNK2005: _malloc already defined in
LIBCMTD.lib(dbgheap.obj)
MSVCRT.lib(MSVCR71.dll) : error LNK2005: _fread already defined in
LIBCMTD.lib(fread.obj)
MSVCRT.lib(MSVCR71.dll) : error LNK2005: _isdigit already defined in
LIBCMTD.lib(_ctype.obj)

(and a whole lot more like this).

I'm thinking that renaming the lib got me past that error and onto The Next
Thing To Be Fixed, but would like confirmation that that is the proper thing
to do.

Thanks.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.secondlife.com/pipermail/sldev/attachments/20071118/e944971a/attachment.htm


More information about the SLDev mailing list