[sldev] code is crashing in CRT

Tateru Nino tateru.nino at gmail.com
Thu Mar 15 00:26:25 PDT 2007


Sounds like you've corrupted the heap, honey. You've overrun or underrun 
some storage somewhere, or written data through a pointer into a block 
that had already been released. The culprit is likely in your own mods. 
Check your arithmetic on ranges, and double-check that you're never 
trying to use an object after it has been freed.

George Williams wrote:
> Hi,
>  
> I think I'm being a bonehead...but I seem to be stuck, so I hope you 
> can help me :)
>  
> I have been compiling the source for slviewer-FL-1.13.3.58877.  I've 
> made very few mods (mostly in viewer.cpp and llcameraview.cpp), and 
> things have been working until now.
>  
> Its now crashing somewhere in the C-RunTime.  I can pinpoint the line 
> of code where it seems to be happening:
>  
> llinventorymodel.cpp, 1486
> ..
> LLViewInventoryCategory* tcat = *cit;
> ..
>  
> I am connecting to Agni, if that matters.  Also, I haven't made any 
> changes to this file (llinventorymodel.cpp).
>  
> Thank you for any leads you might provide to help me with this!
>  
>  
> ------------------------------------------------------------------------
>
> _______________________________________________
> Click here to unsubscribe or manage your list subscription:
> https://lists.secondlife.com/cgi-bin/mailman/listinfo/sldev
>   

-- 
Tateru Nino
http://dwellonit.blogspot.com/



More information about the SLDev mailing list