[sldev] Has anybody tried valgrind?

Tofu Linden tofu.linden at lindenlab.com
Wed Apr 4 11:20:26 PDT 2007


Hi!

alissa_sabre at yahoo.co.jp wrote:
> I tried valgrind, an open source memory leak checker that runs on
> Linux, against 1.14.1.1.  I thought it was a good idea, since recently
> many residents complain on (possible) memory leak.  Unfortuately, it
> didn't work.

I've run Valgrind on the Linux viewer in the past, including a
few times in response to the reports of massive memory leaks (Valgrind
spotted nothing unusual - I've never been able to reproduce these leaks
or find clear commonality between the systems of the particular
residents which suffer from them).

> Has anybody tried valgrind against SL viewer?  How can I use it?  Is
> it possible?
> 
> The following is the error message I got:
> 
> bin/do-not-directly-run-secodlife-bin: error while loading shared libraries: /home/alissa/SecondLife_i686_1_14_1_1_ADITI/lib/libfmod-3.75.so: cannot restore segment prot after reloc: Permission denied

You will likely need to run with LL_VALGRIND=x set to avoid FMOD's
SIMD detection code which fatally confuses Valgrind; this reported
problem, however, looks like something different - probably related
to SELinux.

- Tofu


More information about the SLDev mailing list