[opensource-dev] Review Request: OPEN-99: use -march=pentium3 and -march=pentium4 only for 32 bit builds

Boroondas Gupte sllists at boroon.dasgupta.ch
Sun Jul 10 12:59:47 PDT 2011


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://codereview.secondlife.com/r/351/
-----------------------------------------------------------

(Updated July 10, 2011, 12:59 p.m.)


Review request for Viewer and Nyx Linden.


Changes
-------

Added Nyx Linden to reviewers, as OPEN-79 is assigned to him.


Summary
-------

These flags prevent building for 64-bit (both standalone or non-standalone), so only use them for 32-bit builds.


This addresses bugs CTS-315, OPEN-79 and OPEN-99.
    http://jira.secondlife.com/browse/CTS-315
    http://jira.secondlife.com/browse/OPEN-79
    http://jira.secondlife.com/browse/OPEN-99


Diffs
-----

  doc/contributions.txt e8f2a53c3d6e 
  indra/cmake/00-Common.cmake e8f2a53c3d6e 

Diff: http://codereview.secondlife.com/r/351/diff


Testing
-------

Tried a non-standalone 64-bit build (without using 64-bit prebuilts, though):
	Fails with
		[ 11%] Building CXX object llcommon/CMakeFiles/llcommon.dir/u64.o
		Linking CXX shared library libllcommon.so
		/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible ${SRC_DIR}/build-linux-i686/packages/lib/release/libbreakpad_client.so when searching for -lbreakpad_client
		/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible ${SRC_DIR}/build-linux-i686/packages/lib/release/libaprutil-1.so when searching for -laprutil-1
		/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible ${SRC_DIR}/build-linux-i686/packages/lib/release/libaprutil-1.a when searching for -laprutil-1
		/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible ${SRC_DIR}/build-linux-i686/packages/lib/release/libdb-5.1.so when searching for -ldb-5.1
		/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -ldb-5.1
		collect2: ld returned 1 exit status
		make[2]: *** [llcommon/libllcommon.so] Error 1
		make[1]: *** [llcommon/CMakeFiles/llcommon.dir/all] Error 2
		make: *** [all] Error 2
		ERROR: building default configuration returned 2
		For more information: try re-running your command with --verbose or --debug
	(This is, off course, expected. Will have to produce my own 64bit prebuilts for local use.)

Tried a standalone 64-bit build (after merging OPEN-38 changes):
	Fails by hitting https://jira.secondlife.com/browse/OPEN-100

(Both errors occur much later in the build process than the one that'd occur without this change.)

Tried a non-standalone 32-bit build:
	Fails on https://jira.secondlife.com/browse/OPEN-23 , just as without this change.


Thanks,

Boroondas

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.secondlife.com/pipermail/opensource-dev/attachments/20110710/b48b3c30/attachment.htm 


More information about the opensource-dev mailing list