[JIRA] Commented: (VWR-5173) cannot assign a trigger macro to no-mod, no-transfer gesture

UsikuFarasi Kanarik (JIRA) no-reply at lindenlab.cascadeo.com
Mon Jan 18 13:58:03 PST 2010


    [ http://jira.secondlife.com/browse/VWR-5173?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=160201#action_160201 ] 

UsikuFarasi Kanarik commented on VWR-5173:
------------------------------------------

Dad Oh seems to have shown me a difference in semantics.  To him, I think he sees adding or changing triggers or shortcut key combos as modifying the gesture.

To me, I'm not modifying the gesture itself.  I'm not adding to, taking away, or changing the order of how the gesture 1) types in the local chat window, 2) any sounds it plays, or 3) any animations it makes to my AV.  I'm simply changing the trigger and/or shorcut key combos that trigger it.  It's kinda like reassigning keys that do things on the Windows destop (make Notepad open by using Shift-Ctrl-N, for instance, which is different from the default of no shortcut key combination), and probably very similiar to reassigning keys and key combos to run different features in Mac OS, Linux, Unix, and more than likely other OSes.  A person is not modifying the underlying code...just changing the mnemonic that activates the underlying code.

In other words, I think what I want is to have the permissions to change the mnemonic (trigger) that activates the "code" inside the gesture.  The gesture itself stays unchanged.  Just because the gesture may be marked as no-tranfer and no-modify should not take away my permission to run it as it is internally, by whatever mnemonic works best for me.

> cannot assign a trigger macro to no-mod, no-transfer gesture
> ------------------------------------------------------------
>
>                 Key: VWR-5173
>                 URL: http://jira.secondlife.com/browse/VWR-5173
>             Project: 1. Second Life Viewer - VWR
>          Issue Type: Bug
>          Components: Permissions, User Interface
>    Affects Versions: 1.18.5.3, 1.23
>         Environment: Second Life 1.23.5 (136262) Oct 14 2009 12:08:26 (Second Life Release), built with MSVC version 1400.  CPU: Intel Pentium 4 Willamette (1794 MHz), Memory: 1024 MB, OS Version: Windows 7 Home Premium  (Build 7600), Graphics Card Vendor: ATI Technologies Inc. (XFX ATI Radeon HD 4650 [AGP] - 1 GB video RAM)
>            Reporter: Lex Neva
>
> Steps:
> 1. Acquire a gesture that is marked (no modify), (no tranfer) and you have made active.  The gesture I am seeing this behavior regularly with has animation, sound, and chat components.
> 2. Double-click the gesture to open its properties box.
> 3. You find that the trigger option is blank, as well as the shortcut key combo boxes.  Ignore the shortcut key combo boxes, leaving them blank. Type in a new trigger in its box, such as /ffsl.
> 4. Click save.
> 5. Click preview, to see if the gesture plays.
> 6. Close the properties box  by clinking the "X" in the upper right hand corner of the properties box.
> Observed results:
> An error is generated: "Unable to upload [UUID] due to the following reason: Error in upload request. Please visit http://secondlife.com/support for help fixing this problem.  Please try again later."  Also, the gesture is marked as active, but it does not appear in the gesture drop down list, nor can I type its new trigger in the local chat box to 'play' it.  On reopening the properies box, the trigger option is once again blank.  But you CAN play it by clicking the preview button in that properties box.  I even tried assigning a shortcut key in the blank combo boxes, but if anything, it threw that ugly error even faster, after asking me if I wanted to save the changes.  When I tried assigning both a shortcut key and anew  trigger together, I had forgotten to click "save" first.
> Expected results:
> To have a trigger that can be selected in the gesture drop-down list, or to trigger by typing the macro, or alias, I made as its new trigger in the local chat box.  And not be forced to having both my inventory and this gesture's properties box open in order to use it.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.secondlife.com/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        


More information about the Jira-notify mailing list