[JIRA] Commented: (SNOW-248) OGP Interop fails with "OK data: incorrect parameters"

Gwyneth Llewelyn (JIRA) no-reply at lindenlab.cascadeo.com
Fri Jan 15 10:27:32 PST 2010


    [ http://jira.secondlife.com/browse/SNOW-248?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=160007#action_160007 ] 

Gwyneth Llewelyn commented on SNOW-248:
---------------------------------------

Hmmm. Ok, I managed to replicate Pixel's test: logging in to sim1.vaak (Bonifacio) and do an OGP teleport from the Advanced menu to sim2.vaak (Ahern). It worked flawlessly.

However, any attempt to teleport to outside LL's grid didn't work, it always fails with a bad request (no matter what grid I test with). But at least on my side (OpenSim 0.6.8) I can see a lot of errors popping up, related to "bad authentication":

2010-01-15 10:09:57,343 INFO  - OpenSim.Region.CoreModules.InterGrid.OpenGridProtocolModule [OGP]: path /agent/6fdade32-ced2-4638-b2a8-b73b8bf32b39/rez_avatar/request, segments 5 segment[1] agent Last segment request
2010-01-15 10:09:57,384 INFO  - OpenSim.Region.Framework.Scenes.Scene [CONNECTION BEGIN]: Region Beta Business Park told of incoming root agent Gwyneth Llewelyn (OpenGrid user) d2cdf457-5027-4887-abd8-573c62a85226 (circuit code 458901650)
2010-01-15 10:09:57,384 DEBUG - OpenSim.Region.Communications.OGS1.OGS1UserServices [OGS1 USER SERVICES]: Verifying user session for d2cdf457-5027-4887-abd8-573c62a85226
2010-01-15 10:09:57,422 DEBUG - OpenSim.Region.Framework.Scenes.Scene [CONNECTION BEGIN]: User authentication returned False
2010-01-15 10:09:57,422 ERROR - OpenSim.Region.CoreModules.InterGrid.OpenGridProtocolModule [OGP]: rez_avatar/request failed: Failed to authenticate user Gwyneth Llewelyn (OpenGrid user), access denied.

So this MIGHT be just an OpenSim problem and not related to either Snowglobe and/or the vaak region.

> OGP Interop fails with "OK data: incorrect parameters"
> ------------------------------------------------------
>
>                 Key: SNOW-248
>                 URL: http://jira.secondlife.com/browse/SNOW-248
>             Project: 6. Second Life Snowglobe - SNOW
>          Issue Type: Bug
>          Components: Interop 
>    Affects Versions: Snowglobe 1.2
>         Environment: Snowglobe 1.2.0 (2785) Sep 23 2009 18:49:42 (Snowglobe Test Build)
> Release Notes
> Built with GCC version 40001
> CPU: Dual i386 (Unknown) (2000 MHz)
> Memory: 2560 MB
> OS Version: Darwin 9.8.0 Darwin Kernel Version 9.8.0: Wed Jul 15 16:55:01 PDT 2009; root:xnu-1228.15.4~1/RELEASE_I386 i386
> Graphics Card Vendor: Intel Inc.
> Graphics Card: Intel GMA 950 OpenGL Engine
> OpenGL Version: 1.2 APPLE-1.5.48
> libcurl Version: libcurl/7.16.3 OpenSSL/0.9.7l zlib/1.2.3
> J2C Decoder Version: KDU
> Audio Driver Version: FMOD version 3,750000
> LLMozLib Version: [LLMediaImplLLMozLib] - 2.01.27097 (Mozilla GRE version 1.8.1.21_0000000000)
>            Reporter: Gwyneth Llewelyn
>            Assignee: Infinity Linden
>            Priority: Low
>             Fix For: Snowglobe mysterious future
>
>         Attachments: gridnauts.JPG, interop fails.jpg
>
>
> Tried the latest build of Snowglobe 1.2.0 (2785) with the --ogp flag on Mac OS X 10.5.8 and selected several URLs from this list: http://wiki.secondlife.com/wiki/Open_Grid_Public_Beta/Public_Regions (I run a few which I'm sure that have OGP enabled, and so does LL's).
> I always get a popup after an *apparent* successful login which says:
> OK data: Incorrect parameters
> If you feel this is an error, please contact
> support at secondlife.com
> Unless my avatar lost its "Gridnaut" capabilities as of today, this is strange...
> The log shows (keys deleted for security reasons):
> 2009-09-24T23:01:03Z INFO: setStartupState: Startup state changing from STATE_LOGIN_WAIT to STATE_LOGIN_CLEANUP
> 2009-09-24T23:01:03Z INFO: idle_startup: Attempting login as: Gwyneth Llewelyn
> 2009-09-24T23:01:03Z INFO: loadSettingsFromDirectory: Attempting to load settings for the group PerAccount - from location Account
> 2009-09-24T23:01:03Z INFO: loadSettingsFromDirectory: Loaded settings file /Users/lms/Library/Application Support/SecondLife/gwyneth_llewelyn/settings_per_account.xml
> 2009-09-24T23:01:03Z INFO: loadFile: Loading history.xml file at /Users/lms/Library/Application Support/SecondLife/gwyneth_llewelyn/url_history.xml
> 2009-09-24T23:01:03Z INFO: setStartupState: Startup state changing from STATE_LOGIN_CLEANUP to STATE_LOGIN_AUTH_INIT
> 2009-09-24T23:01:03Z INFO: rewriteURI: Rewriting https://login.agni.lindenlab.com/cgi-bin/login.cgi
> 2009-09-24T23:01:04Z INFO: rewriteResult: [0] https://login.agni.lindenlab.com/cgi-bin/login.cgi
> 2009-09-24T23:01:04Z INFO: setStartupState: Startup state changing from STATE_LOGIN_AUTH_INIT to STATE_LOGIN_AUTHENTICATE
> 2009-09-24T23:01:04Z INFO: idle_startup:  URI to POST to : https://login.agni.lindenlab.com/cgi-bin/login.cgi
> 2009-09-24T23:01:04Z INFO: idle_startup:  Post to AgentHostAuth: <llsd><map><key>agree_to_tos</key><integer>0</integer><key>authenticator</key><map><key>algorithm</key><string>md5</string><key>secret</key><string>---xxx---</string><key>type</key><string>hash</string></map><key>id0</key><string>---xxx---</string><key>identifier</key><map><key>first_name</key><string>Gwyneth</string><key>last_name</key><string>Llewelyn</string><key>type</key><string>agent</string></map><key>mac_address</key><string>---xxx---</string><key>read_critical</key><integer>0</integer></map></llsd>
> 2009-09-24T23:01:04Z INFO: setStartupState: Startup state changing from STATE_LOGIN_AUTHENTICATE to (state #8)
> 2009-09-24T23:01:05Z INFO: completed:  Response From AgentHostAuth: <llsd><map><key>login</key><string>false</string><key>message</key><string>Incorrect parameters.
> If you feel this is an error, please contact
> support at secondlife.com.</string><key>reason</key><string>data</string></map></llsd>
> 2009-09-24T23:01:05Z INFO: completed: LLAgentHostAuthResponder error 200 OK
> 2009-09-24T23:01:05Z INFO: LLNotificationHistoryChannel::savePersistentNotifications: Saving open notifications to /Users/lms/Library/Application Support/SecondLife/user_settings/open_notifications.xml
> 2009-09-24T23:01:05Z WARNING: LLAlertDialog: Alert: OK data: Incorrect parameters.
> If you feel this is an error, please contact
> support at secondlife.com.
> 2009-09-24T23:01:05Z INFO: setStartupState: Startup state changing from (state #8) to STATE_LOGIN_SHOW

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.secondlife.com/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        


More information about the Jira-notify mailing list