[JIRA] Issue Comment Edited: (VWR-3258) Rendering glitches: triangle glitches, vertex tears, etc. on some ATI cards with VBO on

Hypatia Callisto (JIRA) no-reply at lindenlab.cascadeo.com
Fri Jan 1 08:08:10 PST 2010


    [ http://jira.secondlife.com/browse/VWR-3258?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=156319#action_156319 ] 

Hypatia Callisto edited comment on VWR-3258 at 1/1/10 8:06 AM:
---------------------------------------------------------------

folks, don't post your NVIDIA bugs here, this is not an NVIDIA issue. Latest drivers on NVIDIA work really well in SL, however good luck if you get them installed on some motherboard chipsets. This was why I finally went ATi (they have DX11 boards now and NVIDIA doesn't... this fact needs to be recognised by LL as more people go ATi these days) and made sure that my new computer had an Intel chipset on my motherboard (of course being i7 this wasn't really an issue). My 7600GS on my P4 is no longer able to be upgraded in NVIDIA drivers due to the motherboard and NVIDIA not getting along, even though the card is perfectly capable of running SL, and therefore many of these issues people are posting about NVIDIA I can verify is due to the outdated drivers, as i experience them on it. My other computer (a Pentium D, dual core) with VIA chipset can't be upgraded to any card higher than 8600GTS due to the MB not getting along with PCI 2.0 and just about anything else which is modern in sound or graphics when the two are combined. 

So I expect to probably see some of these ATi bugs on my new system once its delivered, and so I voted on this JIRA, I'll be sure to post specs and results once I have it here and can test SL on it. But I am happy to eventually say good riddance to my VIA and NVIDIA issues so disabling VBO is a small price to pay in SL!

btw, latest NVIDIA driver as of right now will report in SL as 8.17.0011.9562. if your last four digits is lower than this, you have outdated drivers and need to update them.

      was (Author: Hypatia Callisto):
    folks, don't post your NVIDIA bugs here, this is not an NVIDIA issue. Latest drivers on NVIDIA work really well in SL, however good luck if you get them installed on some motherboard chipsets. This was why I finally went ATi (they have DX11 boards now and NVIDIA doesn't... this fact needs to be recognised by LL as more people go ATi these days) and made sure that my new computer had an Intel chipset on my motherboard (of course being i7 this wasn't really an issue). My 7600GS on my P4 is no longer able to be upgraded in NVIDIA drivers due to the motherboard and NVIDIA not getting along, even though the card is perfectly capable of running SL, and therefore many of these issues people are posting about NVIDIA I can verify is due to the outdated drivers, as i experience them on it. My other computer (a Pentium D, dual core) with VIA chipset can't be upgraded to any card higher than 8600GTS due to the MB not getting along with PCI 2.0 and just about anything else which is modern in sound or graphics when the two are combined. 

So I expect to probably see some of these ATi bugs on my new system once its delivered, and so I voted on this JIRA, I'll be sure to post specs and results once I have it here and can test SL on it. But I am happy to eventually say good riddance to my VIA and NVIDIA issues so disabling VBO is a small price to pay in SL!
  
> Rendering glitches: triangle glitches, vertex tears, etc. on some ATI cards with VBO on
> ---------------------------------------------------------------------------------------
>
>                 Key: VWR-3258
>                 URL: http://jira.secondlife.com/browse/VWR-3258
>             Project: 1. Second Life Viewer - VWR
>          Issue Type: Bug
>          Components: Graphics
>    Affects Versions: 1.20 Release Candidate, 1.20, First Look: WindLight, 1.19.1.4, 1.21, 1.22, 1.23 Release Candidate, 1.23
>         Environment: Any simulation with objects.
>            Reporter: Trice Beam
>            Assignee: WorkingOnIt Linden
>            Priority: Critical
>         Attachments: 33.bmp, 34.bmp, 35.jpg, 36.jpg, 37.jpg, 38.jpg, 39.jpg, 40.jpg, 9.10.08.jpg, 9.15.08.jpg, aaaahhhh_001.bmp, artifacting.jpg, ATI control panel.jpg, aug.sept.jpg, Bugshot--Triangle-Explosion.png, controlpanel.jpg, Dripping AV.jpg, how i login now.jpg, how i used to login.jpg, Nvidia1.jpg, Nvidia2.jpg, Nvidia3.jpg, screenshot-1.jpg, screenshot-10 artifacts appearing on enabling VBO with hd 4890 ati video card.jpg, screenshot-2.jpg, screenshot-3.jpg, screenshot-4.jpg, screenshot-5.jpg, screenshot-6.jpg, screenshot-7.jpg, screenshot-8.jpg, screenshot-9.jpg, Snapshot_003.bmp, triangle1.BMP, Triangle2.BMP, Triangles Reflecting in water.jpg, Vertex tear in normal view (fixed with fast alpha).JPG, Vertex tear in normal view.JPG, Vertex tear in wireframe (fixed with fast alpha).JPG, Vertex tear in wireframe.JPG, vertex tear without vbo.jpg, vertex_inOnRez01_001.png, vertex_inOnRez01_002.png, vertex_inOnRez01_003.png, vertexbug_002.jpg, vertexbug_006.jpg, vertexbug_011.jpg, what i seen up till update.tga, x850issue.jpg
>
>
> This is also happening to Nvidia cards ,as confirmed by Jira residents.
> This happens on both the RC and main 1.19.1.4 .
> Latest Forceware used.
> Second Life 1.20.0 (84432) Apr  9 2008 03:59:09 (Second Life Release)
> CPU: Intel Core 2 Series Processor (2671 MHz)
> Memory: 1024 MB
> OS Version: Microsoft Windows XP Service Pack 2 (Build 2600)
> Graphics Card Vendor: NVIDIA Corporation
> Graphics Card: GeForce 7950 GT/PCI/SSE2
> OpenGL Version: 2.1.2
> LLMozLib Version: [LLMediaImplLLMozLib] - 2.01.14421 (Mozilla GRE version 1.8.1.13_0000000000)
> However on Nvidia cards usually only Objects are affected(Sculpties seems to have the most affect).
> This changes with VBO off, Laggy but no more of these graphical glitches.
> --------
> Status (as of April 10, 2008, from the meeting described here: http://blog.secondlife.com/2008/04/09/1191-viewer-a-lovehate-relationship/ ):
> This was traced to a problem with ATI's drivers - LL is working with them towards a solution.  While they're fixing this, you can try turning VBO off, then set your graphics settings to LOW and adjust upwards from there.  It won't be as fast as it should be, but it'll be usable until this gets fixed.  (To access your settings before sign-in, go to Edit -> Preferences.)
> ===
> Original summary: VBO render bug with objects on ATI graphics cards blocking the view.
> On my Older spare backup "pentuim 4 Extreme edtion 3.4 ghz with a ati x1950 pro 512mb " objects will sometimes not render in the correct way often causing disply courrption in the geomotry making the object lose it's shape and block the screen. It looks like a vertex rendering error but the screen is so messed up i can never tell exactly what objects are doing it. 
> see picture of screen attachment the screen is filled with many rendering errors On screen shot the entire screen is filled with error render objects covering the right hand HUD and center of screen ETC. 
> This effect is more noticeable the more the camrea is rotated. 
> (I have posted a screen from the non-windlight viewer to show how the area objects should be rendered.)
> This does not happen on My other quad core machine with a nvida 8800 GTX using Vista or windows XP sp2. 
> But has seem to effect other peoples system with an x1000 series card. (ati x1300,1600,1800 ETC)
> since many with ATI gpus seem to have this issue and you can not see anything in the game when this happens I listed it as "critical"
> I was running it with Graphics detail set to "ultra" and in window mode with desktop res set to 1280x1024 under an fully updated windows xp SP2. 
> This has happend with other version of the viewer  but is happens far more often on this version of windlight the moment you log on every time. 
> (repost of this issue since I made a major personal mistake on the first post.)
> System specs detailed 
> =---------------------------------- 
> Property Value 
> Manufacturer ASUSTeK Computer Inc. 
> Model P4C800-E 
> Version Rev 1.xx 
> Serial Number MB-1234567890 
> Chipset Vendor Intel Corporation 
> Chipset Model 82875P,E7210 Memory Controller Hub 
> North Bridge Intel 875P 
> South Bridge 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge 
> SMBus Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller @0400h 
> CPU Intel Pentium 4 XE 
> Cpu Socket Socket 478 [CPU 1] 
> Processor Upgrade 
> Max CPU Speed 3600 MHz 
> System Slots 5 PCI, 1 AGP 
> OnBoard devices 
> Ethernet (Enabled) Intel CSA 82547EI 
> Memory Summary 
> Location System board or motherboard 
> Maximum Capacity 4096 MBytes 
> Memory Slots 4 
> Error Correction Single-bit ECC 
> Use System memory 
> Maximum Memory Module Size 1024 MBytes 
> Warning! Accuracy of DMI data cannot be guaranteed 
> Property Value 
> Manufacturer To Be Filled By O.E.M. 
> Product Name To Be Filled By O.E.M. 
> Version To Be Filled By O.E.M. 
> Serial Number To Be Filled By O.E.M. 
> Chassis Desktop 
> Infrared (IR) Supported No 
> Machine Type AT/AT COMPATIBLE 
> UUID 03000200-0400-0500-0006-000700080009 
> Physical Memory 2047 MB Total, 1168 MB Free 
> Memory Load 42% 
> Virtual Memory 3944 MB Total, 2817 MB Free 
> PageFile Name \??\C:\pagefile.sys 
> PageFile Size 2047 MB 
> In use 398 MB 
> Max used 398 MB 
> Registry Size 2 MB (current), 119 MB (maximum) 
> Profile GUID {080b03c0-8d72-11dc-bce8-806d6172696f} 
> The system clock interval 15 ms 
> Warning! Accuracy of DMI data cannot be guaranteed 
> pci devices 
> ---------------------- 
> Bus/Dev./Func. Type Class Type Manufacturer Device Name Sub System Device Vendor Sub System Device Name 
> 00 / 00 / 00 PCI PCI to HOST Bridge Intel Corporation 82875P,E7210 Memory Controller Hub ASUSTeK Computer Inc 
> 00 / 01 / 00 PCI PCI to PCI Bridge Intel Corporation 82875P PCI to AGP Bridge 
> 00 / 03 / 00 PCI PCI to PCI Bridge Intel Corporation 82875P,E7210 PCI to CSA Bridge 
> 00 / 29 / 00 PCI USB (UHCI) Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 ASUSTeK Computer Inc 
> 00 / 29 / 01 PCI USB (UHCI) Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 ASUSTeK Computer Inc 
> 00 / 29 / 02 PCI USB (UHCI) Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #3 ASUSTeK Computer Inc 
> 00 / 29 / 03 PCI USB (UHCI) Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #4 ASUSTeK Computer Inc 
> 00 / 29 / 07 PCI USB 2.0 (EHCI) Intel Corporation 82801EB/ER (ICH5/ICH5R) USB 2.0 EHCI Controller ASUSTeK Computer Inc 
> 00 / 30 / 00 PCI PCI to PCI Bridge Intel Corporation 801EB/ER Hub Interface to PCI Bridge (ICH5/ICH5R A2/A3 step) 
> 00 / 31 / 00 PCI PCI to ISA Bridge Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge 
> 00 / 31 / 01 PCI IDE (ATA) Intel Corporation 82801EB/ER (ICH5/ICH5R) EIDE Controller ASUSTeK Computer Inc 
> 00 / 31 / 02 PCI IDE (ATA) Intel Corporation 82801EB (ICH5) SATA Controller ASUSTeK Computer Inc 
> 00 / 31 / 03 PCI SMBus Controller Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller ASUSTeK Computer Inc 
> 01 / 00 / 00 AGP VGA Controller ATI Technologies Inc Radeon X1950 Pro (PCIe) PC Partner Ltd 
> 01 / 00 / 01 PCI Other Display Controller ATI Technologies Inc Radeon X1950 Pro (Secondary) (PCIe) PC Partner Ltd 
> 02 / 01 / 00 PCI Ethernet Intel Corporation 82547EI Gigabit Ethernet Controller (LOM) ASUSTeK Computer Inc 
> 03 / 03 / 00 PCI OHCI FireWire VIA Technologies Inc VT6306 VIA Fire II IEEE-1394 OHCI Link Layer Controller ASUSTeK Computer Inc 
> 03 / 11 / 00 PCI Audio Device Creative Labs Sound Blaster X-Fi Creative Labs Sound Blaster X-Fi Fatal1ty 
> 03 / 12 / 00 PCI Other Mass Storage Controller Promise Technology Inc PDC20268 Ultra100 TX2 EIDE Controller Promise Technology Inc PDC20268 Ultra100 TX2 EIDE Controller 
> ------------------------------------------------- 
> video card 
> Property Value 
> Number of GPUs 2 
> Number of GPUs in SLI mode 203 
> Display Adapter Radeon X1950 Pro 
> Video Processor ATI Radeon Graphics Processor AGP (0x7280) 
> Video memory size 512 MBytes 
> Adapter DAC Type Internal DAC(400MHz) 
> BIOS Date 12/04/06 
> Display Drivers ati2dvag.dll 
> Driver Version 6.14.10.6727 
> Driver Date 2007-09-29 03:05:59 
> Inf File Name oem12.inf 
> Inf Section ati2mtag_R580 
> Display Adapter Radeon X1950 Pro Secondary 
> Video Processor ATI Radeon Graphics Processor AGP (0x72A0) 
> Video memory size 512 MBytes 
> Adapter DAC Type Internal DAC(400MHz) 
> Display Drivers ati2dvag.dll 
> Driver Version 6.14.10.6727 
> Driver Date 2007-09-29 03:05:59 
> Inf File Name oem12.inf 
> Inf Section ati2mtag_R580 
> Name Radeon X1950 Pro 
> Chip Type ATI Radeon Graphics Processor AGP (0x7280) 
> DAC Type Internal DAC(400MHz) 
> Memory 512 MBytes 
> ------------------------------ 
> CPU 
> ------------------------ 
> Property Value 
> Number of CPU(s) One Physical Processor / One Core / 2 Logical Processors 
> Vendor GenuineIntel 
> CPU Full Name Intel Pentium 4 XE 
> CPU Name Intel(R) Pentium(R) 4 CPU 3.40GHz 
> CPU Code Name Gallatin 
> Technology 0.13µ 
> Platform Name Socket 478 
> Type Original OEM processor 
> FSB Mode QDR 
> Platform ID 2 
> Microcode ID 2B 
> Type ID 0 
> CPU Clock 3398.39 
> System Bus Clock -1.0 
> System Clock 199.91 
> Multiplier 17.00 
> Original Clock 3400.00 
> Original Bus Clock 800.00 
> Original System Clock 200.00 
> Original Multiplier 17.00 
> L2 Cache Speed 3398.39 MHz 
> L2 Cache Speed Full 
> CPU Family / Model / Stepping F / 2 / 5 
> Brand ID 09 
> APIC 01 
> HyperThreading 2 
> L1 T-Cache 12 KµOps 
> L1 D-Cache 8 KB 
> L2 Cache 512 KB 
> L3 Cache 2048 KB 
> RDMSR 00000080 00000000 11120011 00000000 
> MMX Yes 
> SSE Yes 
> SSE2 Yes 
> SSE3 No 
> SSSE3 No 
> DualCore No 
> HyperThreading Yes 
> IA-64 No 
> Intel 64 (EM64T) No 
> XD No 
> VT No 
> SpeedStep No 
> Architecture x86  

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.secondlife.com/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       


More information about the Jira-notify mailing list